首页 » 技术讨论 » 正文

User manager 配置指南

User manager是集成在RouterOS的一个功能包,可用于管理PPPOE,HOTSPOT等用户账号,我们使用前要确认RouterOS的system package里有user manager功能包。

userman-1
如果没有安装功能包,那么就需要下载一个RouterOS相同版本的user-manager.nkp。上传到files文件根目录下。通过reboot命令重启安装功能包。
在确认安装功能包后。我们登录user manager通过web页面和命令行配置,命令行在tool user-manager目录下配置。

User manager的web登录默认是80端口。访问路径为http://192.168.88.1/userman
userman-2
User manager默认的登录名为admin,密码为空。登录后:
userman-3

 

您可以将userman汉化成中文后使用:http://www.rosjb.com/?p=513

 

*使用命令行登录usermanager

[admin@MikroTik] > tool user-manager
[admin@MikroTik] /tool user-manager>

示例:修改user manager默认登录帐号admin的密码(设置为123)。
[admin@MikroTik] /tool user-manager>customer
[admin@MikroTik] /tool user-managercustomer> print
Flags: X – disabled
0 login=”admin” password=”123″ backup-allowed=yestime-zone=-00:00
permissions=ownersignup-allowed=no paypal-allowed=no
paypal-secure-response=no paypal-accept-pending=no
[admin@MikroTik] /tool user-managercustomer> set 0 password=123

Usermanager操作界面介绍
userman-4

菜单栏:
Routers:连接到user manager的路由器IP地址和secret等参数
Users:用户帐号信息添加、编辑、删除等
Sessions:用户认证管理
Customers:添加顾客管理系统,可以建立多个用户管理系统
Logs:认证日志
Payments:用户付款记录信息
Profiles:用户计费策略
Settings:user manager网页设置参数、语言设置和网银付款接口设置
Reports:导出user manager统计报告
A users:在线用户
Advanced search:高级搜索
Maintenance:数据维护
Logout:退出

功能区域:
Add:添加一个新的规则
Edit:对选中的规则进行编辑
Generate:生成备份文件

友情提示:

6.x用户,如果发现自己无法创建usermanager数据库,首先查看winbox里files目录里是否有user-manager文件夹,如果没有在控制台输入:

/tool user-manager database set db-path=user-manager   (如果生成不了,修改成user-manager1)两者都可尝试)

然后会看见files文件夹以及数据库创建完毕.就可以正常使用了!

原文来自官方论坛: http://forum.mikrotik.com/viewtopic.php?t=92177

 

 

发表评论