首页 » 技术讨论 » 正文

[转载]ROS电信+网通双线,指定某IP只走电信线或网通!

ROS电信+网通双线,指定某IP只走电信线或网通线!

当初萌发念头要做这个的时候是想到,有时候自己抓路由表的时候,搞的不太准,实在不知道某个IP到底是走电信好,还是走网通好,而且有时顾客因为线路选择 错误。导致游戏比较卡,我给他强制单线,他还叫卡。真就是与俺没关系了。所以呢就考虑到了做这个,个人感觉比较有用。前提双线路由已经搞定。我设定一些 IP段。比如
192.168.0.X — 是双线自动切换。
192.168.1.X — 是单电信线。
192.168.2.X — 是单网通线。
我的内网三个网关分别是192.168.0.1、192.168.1.1、192.168.2.1
那么如何做呢?很简单的。。。
***************************************************************
★★ip–firewall–mangle添加一个路由标记。单电信的。
点+号
General页
chain: prerouting
Src.Address: 192.168.1.2-192.168.1.254
—————————————————————
Action页
Action: mark routing
New Routing Mark: only-tel(自己定义,我的意思是单电信内网IP段)
Passthrough打钩
===============================================================
★★ip–firewall–mangle再添加一个路由标记。单网通的。
点+号
General页
chain: prerouting
Src.Address: 192.168.2.2-192.168.2.254
—————————————————————
Action页
Action: mark routing
New Routing Mark: only-cnc(自己定义,我的意思是单网通)
Passthrough打钩
===============================================================
那么标记这里就完成了。。到路由表里去指定这两个标记的默认路由网关。
★★ip–Routes
点+号
Destination: 0.0.0.0/0
Gateway: 电信网关
Check Gateway: ping
Distance: 0
Mark: only-tel (这里就是指定刚才建立的路由标记了。)
然后OK。。单电信IP段搞定。
—————————————————————
同样再加一个单网通路由标记的默认路由网关。和上面一样。电信改网通就行了。
★★ip–Routes
点+号
Destination: 0.0.0.0/0
Gateway: 网通网关
Check Gateway: ping
Distance: 0
Mark: only-cnc (这里就是指定刚才建立的路由标记了。)
然后OK。。单网通IP段搞定。
================================================================
那如果单电信或单网通掉线了咋办?总不能不上网吧?当然不能哈。加个
判断脚本。。
下面做个脚本监测 某条公网线路down掉后,自动切换到另外一条
创建四个脚本,命令如下
/ system script
add name=”only-tel-down” source=”/ip route set only-tel gateway=网通网关” 
policy=ftp,reboot,read,write,policy,test,winbox,password
add name=”only-tel-up” source=”/ip route set only-tel gateway=电信网关” 
policy=ftp,reboot,read,write,policy,test,winbox,password
add name=”only-cnc-up” source=”/ip route set only-cnc gateway=网通网关” 
policy=ftp,reboot,read,write,policy,test,winbox,password
add name=”only-cnc-down” source=”/ip route set only-cnc gateway=电信网关” 
然后设置网络连接监测(此处的蓝色关系到脚本名字,上面蓝色处)
/ tool netwatch
add host=电信网关 timeout=30ms interval=1s up-script=only-tel-up 
down-script=only-tel-down comment=”” disabled=no
add host=网通网关 timeout=30ms interval=1s up-script=only-cnc-up 
down-script=only-cnc-down comment=”” disabled=no

其实搞这么多完全可以DIY自己的想法的,我写的只是其中一种办法,大家
可以变通来搞的。。。
比如我网吧3层楼。1楼我想单电信线。2楼我单网同。3楼收费高,就双线。
那我就可以把1楼的IP段标记为单电信,2楼我标记单网通,3楼默认main。
那么顾客就有自己的选择了。如果想做在一个楼层,还想使用双线,那就
麻烦点。。。自己手动切换~~